3 Commits

  1. 9
      CHANGELOG.md
  2. 3
      assets/js/editor.js
  3. 942
      assets/package-lock.json
  4. 14
      assets/package.json
  5. 2
      mix.exs

9
CHANGELOG.md

@ -5,6 +5,15 @@ See [Conventional Commits](Https://conventionalcommits.org) for commit guideline
<!-- changelog -->
## [v0.20.0](https://git.inhji.de/inhji/mirage/compare/v0.19.2...v0.20.0) (2021-02-10)
### Features:
* add tab handling to editor
## [v0.19.2](https://git.inhji.de/inhji/mirage/compare/v0.19.1...v0.19.2) (2021-02-09)

3
assets/js/editor.js

@ -1,7 +1,7 @@
import {keymap, EditorView} from "@codemirror/view"
import {EditorState} from "@codemirror/state"
import {history, historyKeymap} from "@codemirror/history"
import {defaultKeymap} from "@codemirror/commands"
import {defaultKeymap, defaultTabBinding} from "@codemirror/commands"
import {defaultHighlightStyle} from "@codemirror/highlight"
import {markdown} from "@codemirror/lang-markdown"
import {oneDark} from "@codemirror/theme-one-dark"
@ -28,6 +28,7 @@ export default function initEditor(element) {
defaultHighlightStyle,
keymap.of([
...defaultKeymap,
...defaultTabBinding,
...historyKeymap
]),
]

942
assets/package-lock.json
File diff suppressed because it is too large
View File

14
assets/package.json

@ -6,8 +6,8 @@
},
"dependencies": {
"@codemirror/basic-setup": "^0.17.1",
"@codemirror/lang-markdown": "^0.17.1",
"@codemirror/theme-one-dark": "^0.17.4",
"@codemirror/lang-markdown": "^0.17.2",
"@codemirror/theme-one-dark": "^0.17.5",
"minireset.css": "0.0.6",
"nprogress": "^0.2.0",
"phoenix": "file:../deps/phoenix",
@ -20,13 +20,13 @@
"babel-loader": "^8.x",
"babel-plugin-prismjs": "^2.0.1",
"copy-webpack-plugin": "^7.x",
"css-loader": "^5.x",
"css-loader": "^5.0.2",
"css-minimizer-webpack-plugin": "^1.x",
"file-loader": "^6.x",
"mini-css-extract-plugin": "^1.x",
"sass": "^1.x",
"sass-loader": "^11.x",
"webpack": "5.x",
"mini-css-extract-plugin": "^1.3.6",
"sass": "^1.32.7",
"sass-loader": "^11.0.1",
"webpack": "^5.21.2",
"webpack-cli": "^4.x"
}
}

2
mix.exs

@ -1,7 +1,7 @@
defmodule Mirage.MixProject do
use Mix.Project
@version "0.19.2"
@version "0.20.0"
def project do
[

Loading…
Cancel
Save